Torantrieb Halterung hält nicht

      Torantrieb Halterung hält nicht

      Hallo miteinander, ich habe einen torantrieb aufgebaut.
      Es handelt sich um ein zweiflügeliges Drehtor. Die beiden Antriebe sind jeweils an den Metallpfosten meines Zauns angeschweißt.
      Leider hält dieser Verbindung offenbar jeweils nur einige Wochen. Dann fällt der jeweilige Antrieb ab.
      Ich bin absoluter Laie, und habe vor der Montage der Antriebe nie geschweißt (nur vor Montage einige Zeit "geübt).
      Wer kann Hilfestellung geben, warum die Verbindung nicht hält?
      Erste Ursache könnte meiner Meinung nach in den verwendeten Materialien zu suchen sein.
      Pfosten : unbekanntes Metall, ist an verschiedenen Stellen geschweißt.
      Halterung: Pfostenhalter für holzbau, aus Stahl, verzinkt, 4mm. Vor dem schweißen abgeschliffen.

      Schweißgerät elektro 24v 80A, DDR - gerät, auf höchster Stufe geschweißt, "universalelektrode" (genauen Typ kann ich noch nachliefern)

      Meine Schweißnähte sehen natürlich alles andere als super aus, aber das die Verbindung eine so geringe Lebensdauer hat, halte ich für ungewöhnlich... ? Für tips bin ich dankbar :)
      Bei der Suche der Versagensursache gibt es mindestens zwei Aspekte zu beachten:
      1. Ungünstige Konstruktion, Krafteinleitung verbesserungswürdig, usw.
      2. Schweißfehler: Profis können anhand der Bilder der Schweißnähte und des Versagensbildes viel dazu sagen.
      Du willst doch was Qualifizierteres als "das sozialistische Schweißgerät verträgt sich nicht mit der kapitalistischen Elektrode" hören, oder?!